Issue with UK Cluster 1 - Degraded Performance

Incident Report for Progress MOVEit Cloud

Update

We are continuing to investigate this issue.
Posted Sep 16, 2026 - 21:50 CDT

Investigating

We are currently observing performance degradation on UK cluster 1
Posted Sep 16, 2026 - 21:42 CDT
This incident affects: UK Cluster 1.