Mailjet - Outgoing message sending delays
Incident Report for Progress MOVEit Cloud
Resolved
Mailjet has reported that a fix has been implemented and they are monitoring the results.
Posted Dec 11, 2020 - 12:00 CST
Identified
We wanted to share that the trusted email platform/service that we use for MOVEit Cloud (Mailjet) has been experiencing message sending delays this morning and they have identified the issue and are working on implementing a fix.

https://status.mailjet.com/#

We will send out an update when Mailjet confirms that this has been resolved.
Posted Dec 11, 2020 - 11:14 CST
This incident affected: North America - Cluster 1, North America - Cluster 2, and Europe - Cluster 1.