Investigating a potential certificate warning on Cluster 3 ~ North America
Incident Report for Progress MOVEit Cloud
Postmortem

It was found that one node was incorrectly presenting a default certificate, which caused some users to see a certificate warning for a few minutes until it was resolved.

Posted Mar 24, 2023 - 17:09 CDT

Resolved
Hello,

We are currently investigating a potential certificate warning on Cluster 3 ~ North America

We will post another update in an hour or as soon as we learn more.
Posted Mar 14, 2023 - 14:00 CDT