Investigating a potential service issue on Cluster 3

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Apr 21, 2025 - 11:59 CDT

Monitoring

The intermittent service issues. on Cluster 3 have been resolved and we will continue to monitor this closely.
Posted Apr 18, 2025 - 23:11 CDT

Update

We are continuing to investigate this issue.
Posted Apr 18, 2025 - 22:45 CDT

Investigating

Hello,

We are currently investigating a potential SFTP issue on Cluster 3.

We will post another update in an hour or as soon as we learn more.
Posted Apr 18, 2025 - 21:27 CDT
This incident affected: North America - Cluster 3.