Investigating intermittent latency issues on North America Cluster 1, 2, and 3 being reported
Incident Report for Progress MOVEit Cloud
Resolved
We're going to close out this alert for now and we'll continue to monitor this closely.
Posted Apr 08, 2024 - 19:16 CDT
Monitoring
The fix has been applied, moving this to monitoring.
Posted Apr 08, 2024 - 11:45 CDT
Identified
We're applying a potential fix and we'll move this to monitoring after the fix has been applied.
Posted Apr 08, 2024 - 11:29 CDT
Update
This is still being investigated and monitored.
Posted Apr 08, 2024 - 09:55 CDT
Update
We're still experiencing intermittent latency and have escalated this issue. We will continue to provide updates hourly or sooner if possible.
Posted Apr 08, 2024 - 08:40 CDT
Investigating
We are currently investigating this issue.
Posted Apr 08, 2024 - 07:18 CDT
Monitoring
We are still currently investigating this issue.
Posted Apr 08, 2024 - 05:59 CDT
Update
MOVEit Cloud North America Cluster 2 is experiencing a degraded performance currently that may impact users and our team is currently working to restore the service to normal performance levels as quickly as possible.

We will post another update in an hour or as soon as we learn more.
Posted Apr 08, 2024 - 05:12 CDT
Investigating
We are currently investigating a potential issue on North America Cluster 2.

We will post another update in an hour or as soon as we learn more.
Posted Apr 08, 2024 - 04:53 CDT
This incident affected: North America - Cluster 1, North America - Cluster 2, and North America - Cluster 3.