Investigating a potential issue on Cluster 3

Incident Report for Progress MOVEit Cloud

Monitoring

We’re seeing positive improvements and a reduction in slowness. Services will remain under active monitoring while we ensure continued stability. We’ll share another update if conditions change.
Posted Apr 16, 2026 - 12:21 CDT

Investigating

Hello,

We are currently investigating a potential issue with slowness being reported for SSH connections on Cluster 3.

We will post another update in an hour or as soon as we learn more.
Posted Apr 16, 2026 - 11:08 CDT
This incident affects: North America - Cluster 3.