MOVEit Cloud - Emergency Maintenance
Incident Report for Progress MOVEit Cloud
Resolved
In response to the recently disclosed Terrapin SSH vulnerability (https://terrapin-attack.com/), the chacha20-poly1305@openssh.com encryption algorithm has been disabled for MOVEit Cloud SSH connections. No further customer action is necessary at this time.
Posted Dec 21, 2023 - 11:07 CST
Investigating
In response to the recently disclosed Terrapin SSH vulnerability (https://terrapin-attack.com/), MOVEit Cloud will be updated to disable the chacha20-poly1305@openssh.com encryption algorithm. Customers may experience a momentary interruption in SSH connections to MOVEit Cloud. Maintenance will begin at 11:30am ET.
Posted Dec 21, 2023 - 10:23 CST
This incident affected: North America - Cluster 1, North America - Cluster 2, North America - Cluster 3, Europe - Cluster 1, Australia - Cluster 1, and UK Cluster 1.