Investigating a potential issue on Cluster 1

Incident Report for Progress MOVEit Cloud

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2026 - 11:55 CDT

Investigating

Hello,

We are currently investigating a potential slowness issue on Cluster 1 North America.

We will post another update in an hour or as soon as we learn more.
Posted Jun 08, 2026 - 11:28 CDT
This incident affects: North America - Cluster 1.