Investigating reports of an SSL cert warning on Cluster 1 NA.
Incident Report for Progress MOVEit Cloud
Resolved
Hello,

We are currently investigating reports of an SSL cert warning on Cluster 1 NA.

We will post another update in an hour or as soon as we learn more.
Posted Mar 22, 2023 - 06:30 CDT