Issues with North America Cluster 1

Incident Report for Progress MOVEit Cloud

Resolved

The incident has been resolved.
Posted Mar 01, 2026 - 16:37 CST

Identified

We have identified the issue and have implemented a fix. We will continue to monitor.
Posted Mar 01, 2026 - 12:55 CST

Investigating

We are currently investigating an issue that is affecting some web traffic on North America Cluster 1
Posted Mar 01, 2026 - 11:45 CST
This incident affected: North America - Cluster 1.