2022 February 13th Scheduled Maintenance
Scheduled for Feb 13, 15:00 - 18:00 CST
Update
SSH Weak Key Exchanges/Ciphers Sunset on 2/13/2022

In order to continue to meet our compliance obligations, SSH weak key exchanges and ciphers will be sunset during our 2/13/2022 maintenance.

Full details on this change can be found in the following kb article: https://community.progress.com/s/article/SSH-Weak-Key-Exchanges-Ciphers-Sunset-on-2-13-2022


This article discusses the steps we will take to maintain Payment Card Industry compliance with regard to discontinuing support for weak SSH Weak key exchanges and ciphers as mandated in PCI-DSS version 3.2.1. While these changes were implemented specifically for regulatory compliance in North America, the ciphers are deprecated throughout the Cloud platform, which will affect European customers and customers in other locations as well. You can find an updated list of regional SSH key exchanges and ciphers in this article.
Posted Jan 06, 2022 - 11:07 CST
Scheduled
We will be performing maintenance on all of the MOVEit Cloud servers and expect there to be downtime for most/all of the maintenance window, so we ask that you plan accordingly.
Posted Dec 20, 2021 - 11:38 CST
This scheduled maintenance affects: North America - Cluster 1, North America - Cluster 2, North America - Cluster 3, Europe - Cluster 1, and Australia - Cluster 1.