MOVEit Cloud North America Cluster 1 – Performance Issues

Incident Report for Progress MOVEit Cloud

Resolved

This incident is now being closed as the system has been confirmed stable with no further performance degradation or reports observed.
Posted May 24, 2026 - 01:46 CDT

Monitoring

The issue has been identified and a fix has been implemented. We are continuing to monitor the environment to ensure stability and will provide a further update if needed.
Posted May 24, 2026 - 00:56 CDT

Investigating

We are currently investigating a potential performance issue with HTTPs/SFTP connections on Cluster 1 North America.
We will post another update in an hour or as soon as we learn more.
Posted May 24, 2026 - 00:07 CDT
This incident affected: North America - Cluster 1.