MOVEit Cloud is currently experiencing an outage that impacts all MOVEIt Cloud users using HTTPS
Incident Report for Progress MOVEit Cloud
Resolved
This incident has been resolved.
Posted May 31, 2023 - 19:06 CDT
Monitoring
HTTPS Service to MOVEIt Cloud has been fully restored at this time.
Posted May 31, 2023 - 15:25 CDT
Update
We're currently rolling out the fix to Production servers and will provide an update as soon as it becomes available.
Posted May 31, 2023 - 09:49 CDT
Identified
A fix has been identified and we're currently testing it before rolling it out into Production.

We will provide an update within the next 1-2 hours.
Posted May 31, 2023 - 07:29 CDT
Update
We're continuing our efforts to restore service as quickly as possible to HTTPS.

We will post another update as more information is available to share in the next few hours.
Posted May 31, 2023 - 06:05 CDT
Update
We're continuing our work to restore service as quickly as possible to HTTPS.

We will post another update as more information is available to share in the next few hours.
Posted May 31, 2023 - 01:50 CDT
Update
We're continuing our work to restore service as quickly as possible to HTTPS and encourage impacted customers to look to use ftps or ssh as a work around until service is fully restored.

We will post another update as more information is available to share in the next few hours.
Posted May 30, 2023 - 20:42 CDT
Update
We are continuing to investigate this issue further to restore service as quickly as possible.

We will post another update within 3 hours or as soon as we learn more.
Posted May 30, 2023 - 16:55 CDT
Update
We are continuing to investigate this issue further and have escalated this internally for additional assistance with restoring service as quickly as possible.

We will post another update in an hour or as soon as we learn more.
Posted May 30, 2023 - 14:47 CDT
Investigating
MOVEit Cloud is currently experiencing an outage that impacts all MOVEIt Cloud users using HTTPS and our team is currently working to restore the service to normal performance levels as quickly as possible.

We will post another update in an hour or as soon as we learn more.
Posted May 30, 2023 - 13:37 CDT
This incident affected: North America - Cluster 1, North America - Cluster 2, North America - Cluster 3, Europe - Cluster 1, Australia - Cluster 1, and UK Cluster 1.