Investigating potential issue on North America Cluster 1

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 05:28 CST

Monitoring

A fix has been implemented and we are currently monitoring the results to ensure stability.
Posted Feb 04, 2025 - 05:14 CST

Investigating

We are currently investigating a potential issue on North America Cluster 1
Posted Feb 04, 2025 - 04:29 CST
This incident affected: North America - Cluster 1.