2021 September 19th Scheduled Maintenance
Scheduled for Sep 19, 15:00 - 18:00 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2021 - 15:29 CST
Scheduled
We will be patching all of the MOVEit Cloud servers and expect there to be minimal downtime for this maintenance window while servers are patched and rebooted.
Posted Jan 07, 2021 - 10:38 CST
This scheduled maintenance affects: North America - Cluster 1, North America - Cluster 2, North America - Cluster 3, and Europe - Cluster 1.