Investigating a potential issue on Cluster 1 North America

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Apr 24, 2026 - 18:18 CDT

Monitoring

We will continue to monitor this closely over the next few hours.
Posted Apr 24, 2026 - 14:56 CDT

Update

We’re continuing to investigate HTTPS connectivity issues affecting Cluster 1. During troubleshooting, Clusters 2 and 3 briefly experienced similar HTTPS connection issues, but service has been restored. We’ll provide another update as more information becomes available.
Posted Apr 24, 2026 - 13:05 CDT

Investigating

Hello,

We are currently investigating a potential issue with HTTPs connections on Cluster 1 North America.

We will post another update in an hour or as soon as we learn more.
Posted Apr 24, 2026 - 12:00 CDT
This incident affected: North America - Cluster 1.