We are currently investigating a potential SSH issue on Cluster 3 North America

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 21:44 CDT

Monitoring

A fix has been implemented and we will monitor it for a few hours before we close out this incident.
Posted Mar 16, 2025 - 19:45 CDT

Investigating

Hello,

We are currently investigating a potential SSH issue on Cluster 3 North America.

We will post another update in an hour or as soon as we learn more.
Posted Mar 16, 2025 - 19:34 CDT
This incident affected: North America - Cluster 3.