MOVEit Cloud North America Cluster 1 – Performance Issues

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 06:11 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2026 - 04:18 CDT

Identified

The issue has been identified and fix is being implemented.
Posted Apr 08, 2026 - 03:24 CDT

Investigating

We are currently observing performance degradation on MOVEit Cloud Cluster 1, which may result in slower response times or intermittent errors for some users.
Posted Apr 08, 2026 - 03:09 CDT
This incident affected: North America - Cluster 1.