Investigating potential issue on North America Cluster 3

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 07:59 CDT

Monitoring

A fix has been implemented and we will continue to monitor closely to ensure stability.
Posted Mar 17, 2025 - 03:20 CDT

Investigating

We are investigating potential issue on North America Cluster 3
Posted Mar 17, 2025 - 02:44 CDT
This incident affected: North America - Cluster 3.