Investigating potential issue on North America Cluster 3
Incident Report for Progress MOVEit Cloud
Resolved
This incident has been resolved.
Posted Apr 08, 2024 - 05:19 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2024 - 03:53 CDT
Investigating
We are currently investigating a potential issue on North America Cluster 3.

We will post another update in an hour or as soon as we learn more.
Posted Apr 08, 2024 - 03:40 CDT
This incident affected: North America - Cluster 3.