North America - Cluster 2 Outage
Incident Report for Progress MOVEit Cloud
Resolved
The incident has been resolved.
Posted Jan 19, 2025 - 13:37 CST
Monitoring
We have restored services and are monitoring.
Posted Jan 19, 2025 - 06:48 CST
Investigating
We are investigating an issue on North America - Cluster 2.
Posted Jan 19, 2025 - 06:34 CST
This incident affected: North America - Cluster 2.