Investigating a potential issue on Cluster 1 North America

Incident Report for Progress MOVEit Cloud

Resolved

Closing this incident out.
Posted Mar 13, 2025 - 13:56 CDT

Monitoring

The reported issue has been resolved. Our team will continue to monitor the situation closely to ensure stability.

Thank you for your patience and understanding.
Posted Mar 12, 2025 - 16:36 CDT

Update

We're still investigating a performance issue in MOVEit Cloud NA Cluster 1 and have escalated this issue.

We will post another update in an hour or as soon as we learn more.
Posted Mar 12, 2025 - 15:09 CDT

Update

We are continuing to investigate this issue.
Posted Mar 12, 2025 - 13:38 CDT

Investigating

Hello,

We are currently investigating a performance issue in MOVEit Cloud NA Cluster 1.

We will post another update in an hour or as soon as we learn more.
Posted Mar 12, 2025 - 12:27 CDT
This incident affected: North America - Cluster 1.