Maintenance for Cluster 4 NA is still in progress

Incident Report for Progress MOVEit Cloud

Resolved

Maintenance on C4 is now complete.
Posted May 17, 2026 - 12:56 CDT

Investigating

We're still currently upgrading MOVEit Cloud Cluster 4 North America and hope to have it only very soon.

We will provide an update as soon as one is available.

All other MOVEit Cloud clusters have successfully completed the planned maintenance and upgrades.
Posted May 17, 2026 - 12:31 CDT
This incident affected: North America - Cluster 4.