Delays in emails processing

Incident Report for Progress MOVEit Cloud

Resolved

Resolved - The incident has been resolved.
Posted Sep 30, 2025 - 14:11 CDT

Update

We are continuing to work on a fix for this issue.
Posted Sep 30, 2025 - 07:56 CDT

Identified

Mailjet is currently reporting delays in email processing:

"We have identified the root cause of the issue. While we are working on getting this resolved, clients will experience inability to log into app.mailjet.com as well as experience email processing delays."
Posted Sep 30, 2025 - 07:56 CDT
This incident affected: Mailjet Outgoing SMTP.