Cluster 2 North America - Slow logings
Incident Report for Progress MOVEit Cloud
Resolved
The issue causing slow logins has been identified and resolved.
Posted May 26, 2022 - 13:54 CDT
Investigating
We've received a few reports over the past few days of slow logins for some customers and we've been extensively investigating and monitoring this cluster.

We will post an update as soon as we have more information to share.
Posted May 26, 2022 - 08:04 CDT
This incident affected: North America - Cluster 2.