Investigating a potential issue on North America C3

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 15:56 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2025 - 13:51 CDT

Investigating

Hello,

We are currently investigating a potential performance issue with the MOVEit Cloud NA Cluster 3 systems.

We will post another update in an hour or as soon as we learn more.
Posted Mar 13, 2025 - 13:23 CDT
This incident affected: North America - Cluster 3.