Cluster 3 NA - Presenting the previous SSH host key

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Jul 15, 2024 - 10:35 CDT

Monitoring

The 4096-bit key has been restored.
Posted Jul 15, 2024 - 08:29 CDT

Investigating

We are aware that Cluster 3 North America is currently presenting the previous SSH server host key and we're working to restore the 4096-bit key that was in use before maintenance.
Posted Jul 15, 2024 - 08:03 CDT
This incident affected: North America - Cluster 3.