Investigating potential issue on North America Cluster 1, 2, 3, Europe and UK

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 06:11 CDT

Monitoring

We have identified and resolved the issue. Services have been restored. We will continue to monitor.
Posted Jun 10, 2025 - 04:58 CDT

Update

We are continuing to investigate the issues.
Posted Jun 10, 2025 - 04:06 CDT

Investigating

We are currently investigating a potential issue on multiple clusters.
Posted Jun 10, 2025 - 02:13 CDT
This incident affected: North America - Cluster 1, North America - Cluster 2, North America - Cluster 3, Europe - Cluster 1, and UK Cluster 1.