Update to the May 31st outage
Incident Report for Progress MOVEit Cloud
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 09:49 CDT
Monitoring
As per the status update on May 31st , we have restored services to the MOVEit Cloud platform following a self-imposed outage on May 30th.  We had detected evidence of a zero-day vulnerability within the platform and out of an abundance of caution and to protect customer data, we disabled the impacted services rapidly, leading to the outage you experienced. This was initially done as unplanned maintenance to allow our security and product teams to remediate the situation.

The Cloud service has been restored to operation following patching and systems investigations. Forensic investigations and monitoring of the situation are still underway and may lead to updated information on this status page.  More details on the incident and our findings can be found here: https://community.progress.com/s/article/MOVEit-Cloud-Info-Regarding-Critical-Vulnerability-May-2023

Customers are strongly advised to review the knowledge base article as it provides guidance on indications of compromise and how to determine if you were impacted.

END OF STATUS.
Posted Jun 02, 2023 - 12:34 CDT
This incident affected: North America - Cluster 1, North America - Cluster 2, North America - Cluster 3, Europe - Cluster 1, Australia - Cluster 1, and UK Cluster 1.