MOVEit Cloud Test Servers Patching and HTTPS restore today

Incident Report for Progress MOVEit Cloud

Resolved

Test server patching has been completed and HTTPS access has been restored.
Posted Jun 01, 2023 - 12:26 CDT

Investigating

MOVEIt Cloud test servers will be patched today and HTTPS access will be restored shortly after.
Posted Jun 01, 2023 - 06:46 CDT