Investigating a potential issue on Cluster 1 North America
Incident Report for Progress MOVEit Cloud
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 22:33 CDT
Monitoring
We're still monitoring this very closely.
Posted Apr 03, 2024 - 20:26 CDT
Investigating
Hello,

We are currently investigating a potential intermittent issue with Cluster 1.

We will post another update in an hour or as soon as we learn more.
Posted Apr 03, 2024 - 19:05 CDT
This incident affected: North America - Cluster 1.