We identified an issue with SFTP/FTP services on Europe Cluster 1

Incident Report for Progress MOVEit Cloud

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 05:27 CDT

Monitoring

We identified a problem with SFTP and FTP services on EU Cluster 1. The issue has been identified and resolved. We will continue to monitor.
Posted Jun 04, 2026 - 04:18 CDT
This incident affected: Europe - Cluster 1.