Investigating a potential issue on Cluster 2

Incident Report for Progress MOVEit Cloud

Resolved

Hello,

We are currently investigating a potential issue with HTTPs/FTPs connections on Cluster 2.

We will post another update in an hour or as soon as we learn more.
Posted Jun 08, 2026 - 13:30 CDT